Results 1 to 12 of 12

Thread: Help, ZX2 clutch problem

  1. #1
    Orange cones fear me. cone-cerned's Avatar
    Join Date
    Dec 2005
    Location
    Woodbine, Texas
    Posts
    4,629

    Default Help, ZX2 clutch problem

    Tuesday night at Track Night in America I had a clutch problem. It happened near the end of the third session. When I shifted into 3rd coming out of Wagon Wheel the clutch pedal stayed on the floor. I limped into the paddock. That apparently cooled things down enough that when I pulled the pedal up off the floor, it returned on its own when I pressed it again. After about 30-40 minutes, the clutch seemed normal. So, I headed home and I did not have any problems. Yesterday the clutch seemed normal.

    Does this sound like it's time to replace the clutch master and slave?

    Does anyone have a current discount code for Rock Auto?
    On the track, I am fearless.
    If you were as slow as me, you wouldn't be afraid either.

    1994 M Edition
    CSP 67

  2. #2
    Team Cheap Bastard
    President & Founder
    sammm's Avatar
    Join Date
    Jan 2004
    Location
    NRH, TX
    Posts
    6,280

    Default

    Is the slave line rubber? Old & crunchy?

    5% off -7990038571746601

  3. #3
    Orange cones fear me. cone-cerned's Avatar
    Join Date
    Dec 2005
    Location
    Woodbine, Texas
    Posts
    4,629

    Default

    The clutch master does not have a reservoir, it shares the brake master cylinder reservoir. There is a rubber line between the two. From the clutch master to the clutch slave there is a hard line.

    A new clutch master cylinder from Rock Auto comes with a new rubber line to go between the two masters.

    PS Thanks for the Rock Auto number.
    Last edited by cone-cerned; 05-10-2018 at 01:21 PM. Reason: added PS
    On the track, I am fearless.
    If you were as slow as me, you wouldn't be afraid either.

    1994 M Edition
    CSP 67

  4. #4

    Default

    C5 Corvettes tend to do that when the clutch fluid gets dirty. Only way I could fix it was with a new slave and new clutch (it needed the clutch). May not apply to you at all.

    Edit
    Try clean fluid to start if it is dirty.
    Last edited by Robert; 05-10-2018 at 01:31 PM.

  5. #5

    Default

    Other than that, how was your TNIA in the ZX2?
    1995 M Edition

  6. #6
    Orange cones fear me. cone-cerned's Avatar
    Join Date
    Dec 2005
    Location
    Woodbine, Texas
    Posts
    4,629

    Default

    The two things I really noticed. One, the unexpected grip of the NEW RE71Rs as compared to my 4 year old Toyo RRs. Number two, I really missed the Ultra Shield seat and 5 point harness. I was sliding all over the seat. The gearing in the transmission is a wide ratio and I just didn't seem to have the right gear for pulling out of Wagon Wheel.

    I was still the slowest guy in the intermediate group. I didn't get any clean or nearly clean laps. I was backing off to let someone by all the time. My best lap, on the Race Chrono, was 1:39.76 sec. I forgot to stop the timer after the sessions, so I had one 4 hour long session. I still have a lot to learn about the Race Chrono. At the time trial on Saturday, I'm going to use Track Addict.

    When I get the clutch problem solved, I will most likely track the ZX2 again someday. I sure was glad the clutch came back after it cooled. I was pretty down, with a not working clutch and a long way to get home.
    On the track, I am fearless.
    If you were as slow as me, you wouldn't be afraid either.

    1994 M Edition
    CSP 67

  7. #7

    Default

    Did you get any video in RaceChrono?
    1995 M Edition

  8. #8
    Orange cones fear me. cone-cerned's Avatar
    Join Date
    Dec 2005
    Location
    Woodbine, Texas
    Posts
    4,629

    Default

    No. Do you need to have the upgraded version? I just have the free version. And and LG Rebel phone. I'm not sure what version of the OS I am running. I have been chasing other rabbits and haven't done much with RaceChrono or the phone.
    On the track, I am fearless.
    If you were as slow as me, you wouldn't be afraid either.

    1994 M Edition
    CSP 67

  9. #9

    Default

    Quote Originally Posted by Robert View Post
    Try clean fluid to start if it is dirty.
    When was the last time you flushed the brakes and clutch?

  10. #10
    Orange cones fear me. cone-cerned's Avatar
    Join Date
    Dec 2005
    Location
    Woodbine, Texas
    Posts
    4,629

    Default

    It's been so long ago that I don't remember. Which means it could have been last week!

    It's actually been almost three years for the brakes. I was ignorant of the connection between the brakes and clutch, so for the clutch branch of the system, it has been about 14 years.
    On the track, I am fearless.
    If you were as slow as me, you wouldn't be afraid either.

    1994 M Edition
    CSP 67

  11. #11

    Default

    Quote Originally Posted by cone-cerned View Post
    I was ignorant of the connection between the brakes and clutch, so for the clutch branch of the system, it has been about 14 years.
    Well, There's Your Problem.....

  12. #12

    Default

    Quote Originally Posted by cone-cerned View Post
    No. Do you need to have the upgraded version? I just have the free version. And and LG Rebel phone. I'm not sure what version of the OS I am running. I have been chasing other rabbits and haven't done much with RaceChrono or the phone.
    I did purchase the 'Full Version'
    1995 M Edition

Similar Threads

  1. 1992 - clutch problem?
    By howardmims in forum Miata Tech and Chat
    Replies: 4
    Last Post: 02-08-2014, 07:22 PM
  2. Possible clutch master or slave cylinder problem?
    By Keifersmith in forum Miata Tech and Chat
    Replies: 4
    Last Post: 07-09-2009, 08:32 PM
  3. Clutch problem
    By MadMonkey in forum Miata Tech and Chat
    Replies: 7
    Last Post: 12-22-2008, 04:49 PM
  4. Hydraulic Clutch Pressure Problem
    By Korwen in forum Miata Tech and Chat
    Replies: 4
    Last Post: 02-19-2007, 01:15 PM
  5. Is this a clutch problem? Troubleshoot
    By cam76034 in forum Miata Tech and Chat
    Replies: 27
    Last Post: 01-17-2007, 07:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •